Delayed emails

Incident Report for WeTransfer

Resolved

The team has resolve this issue.
Posted Jun 19, 2023 - 22:24 UTC

Monitoring

The majority of delayed emails have been processed and we’re monitoring the remaining few. We’re expecting the issue to be resolved in the next 15 minutes.
Posted Jun 19, 2023 - 22:16 UTC

Investigating

Transactional emails (signup, verification, transfer emails) are delayed up to 60 minutes. We believe the issue has been addressed and are processing delayed mails; we expect to be running as usual in the next 60 minutes.
Posted Jun 19, 2023 - 21:34 UTC
This incident affected: WeTransfer (Email).