Scheduled Maintenance
Incident Report for WeTransfer
Resolved
The maintenance has concluded. All services are back to being fully operational.
Posted Oct 27, 2021 - 22:33 UTC
Monitoring
No uploads will start, no new downloaded will start and general website instability might be experienced while we are concluding scheduled maintenance of a critical component of our infrastructure.
Posted Oct 27, 2021 - 22:11 UTC
This incident affected: WeTransfer (Website, Pro, Downloads, Uploads).