Account sign-up and verification issue
Incident Report for WeTransfer
Resolved
This incident has been resolved.
Posted May 19, 2020 - 11:22 UTC
Monitoring
A fix has been implemented and we are monitoring the situation.
Posted May 19, 2020 - 10:43 UTC
Investigating
We've identified an issue with some of our emails, in particular account creation and account verification emails. We are rolling back to a previous known good state and will update here when the situation changes.
Posted May 19, 2020 - 10:36 UTC
This incident affected: WeTransfer (Email).