Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 25, 2023 - 08:00 UTC
Scheduled
We will be performing planned maintenance for a short period of time (~10 minutes) to our transfer service. We are aiming for no impact on our services. If you do experience any issues during this time, please try again in 10 minutes.
Posted Oct 17, 2023 - 07:45 UTC
This scheduled maintenance affected: WeTransfer (Website, Downloads, Uploads, Email, Portals, Transfer Mobile).