Maintenance has been successful. No disruption has been observed. If you do notice anything unusual, please do reach out at help.wetransfer.com.
Posted May 16, 2024 - 08:07 UTC
Update
We are performing some maintenance on our database. We do not expect any disruption to your use of WeTransfer. If you do notice anything unusual, please do reach out at help.wetransfer.com.
Posted May 16, 2024 - 07:35 UTC
Scheduled
Scheduled maintenance of our database
Posted May 16, 2024 - 07:23 UTC
This scheduled maintenance affected: WeTransfer (Downloads, Uploads).