Some users unable to verify via Google sign up

Incident Report for WeTransfer

Resolved

This incident has been resolved. Please try reloading the page and signing in.

We apologise for any inconvenience caused.
Posted Aug 02, 2023 - 15:46 UTC

Investigating

We have received reports from users that they are unable to verify via Google sign-up, they have reported being stuck in a loop after attempting to verify their email. We are currently investigating this issue and working hard to implement a fix.

If you urgently need to send a transfer you can use our link transfer option.
Posted Aug 02, 2023 - 15:00 UTC
This incident affected: WeTransfer (Website, Email).