Unable to access WeTransfer.com
Incident Report for WeTransfer
Resolved
Our engineers were able to identify the issue, get this under control and resolve the problem. The website is now back up and running. We truly apologise for the inconvenience this caused.
Posted Oct 24, 2023 - 13:34 UTC
Update
Our engineers are continuing to work hard to investigate the issue.
Posted Oct 24, 2023 - 12:56 UTC
Investigating
We are currently investigating the issue causing the site to be down. Apologies for the inconvenience. Next update shortly.
Posted Oct 24, 2023 - 12:25 UTC
This incident affected: WeTransfer (Website, Downloads, Uploads, Portals, Transfer Mobile).