Wetransfer.com currently inaccessible
Incident Report for
WeTransfer
Resolved
This incident has been resolved.
Posted
Mar
11
,
2024
-
16:10
UTC
Identified
The issue has been identified and we are currently working on a fix.
Posted
Mar
11
,
2024
-
16:04
UTC
Investigating
Wetransfer.com is down. We are currently investigating the issue and will update shortly
Posted
Mar
11
,
2024
-
15:59
UTC
This incident affected: WeTransfer (Website, Downloads, Uploads, Portals).
×
Subscribe to Incident
Subscribe to updates for
Wetransfer.com currently inaccessible
via . You'll receive .