Downloads not starting in Europe
Incident Report for WeTransfer
Resolved
The EU download cluster is back within the normal performance envelope and all downloads should start and proceed normally.
Posted Nov 09, 2020 - 15:16 UTC
Monitoring
We have applied measuers to our download cluster in EU and are monitoring as the load subsides. Downloads should be starting normally and completing now.
Posted Nov 09, 2020 - 14:54 UTC
Identified
We have identified the elevated load on our EU download infrastructure to be the reason for failing downloads. We are currently implementing a number of fixes to balance the load on our download cluster and introducing extra capacity.
Posted Nov 09, 2020 - 14:08 UTC
Investigating
Transfers and Collect boards stored in our EU region might fail to download. Downloads might be slow and can fail to start.
Posted Nov 09, 2020 - 13:03 UTC
This incident affected: WeTransfer (Downloads).