Wetransfer.com is intermittently unavailable
Incident Report for WeTransfer
Resolved
This incident has been resolved.
Posted Jan 17, 2023 - 13:11 UTC
Update
We are continuing to investigate this issue.
Posted Jan 17, 2023 - 13:11 UTC
Investigating
We are currently investigating this issue.
Posted Jan 17, 2023 - 11:46 UTC
This incident affected: WeTransfer (Website, Downloads).