Wetransfer.com is currently experiencing downtime
Incident Report for WeTransfer
Resolved
We've resolved this issue and everything on the platform is functional again.
Posted Sep 14, 2021 - 16:12 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 14, 2021 - 16:09 UTC
Identified
We've identified the cause of the downtime to the platform. WeTransfer.com is back online, however, we are still debugging this incident.
Posted Sep 14, 2021 - 15:44 UTC
Investigating
We're currently investigating an issue causing downtime on our platform. We're working fast towards getting it back up and running again. Current transfers may fail and email notifications may not be delivered.
Posted Sep 14, 2021 - 14:37 UTC
This incident affected: WeTransfer (Website, Pro, Downloads, Uploads, Email).