Download servers are failing in the EU region
Incident Report for WeTransfer
Resolved
This incident has been resolved and downloads in the EU region can be resumed as expected.
Posted Jan 11, 2023 - 17:12 UTC
Update
We are currently investigating this issue; this may affect downloads in the EU region.
Posted Jan 11, 2023 - 16:09 UTC
Investigating
We are currently investigating this issue; this may affect downloads in the EU region.
Posted Jan 11, 2023 - 16:07 UTC
This incident affected: WeTransfer (Downloads, Transfer Mobile).