Outgoing email issues
Incident Report for WeTransfer
Resolved
After resolving the incident and slowly processing through our backlog everything should be functional again. If you still haven't received your email over the next hour or two - we advice you to reupload your transfer.
Posted 8 months ago. Feb 20, 2019 - 12:27 UTC
Identified
We're facing some issues as the moment resulting in delayed emails and transfer completion. Due to this, it will take longer for your transfer to finish uploading and processing, and for the corresponding email to be sent out. We're investigating the issue and working on a fix.
Posted 8 months ago. Feb 20, 2019 - 12:03 UTC
This incident affected: Uploads and Email.