Slow downloads in EU
Incident Report for WeTransfer
Resolved
Downloads have normalised in EU. We will be monitoring the download cluster and continue our investigation of the failure that led to the incident occurring.
Posted 22 days ago. Sep 23, 2019 - 16:44 UTC
Monitoring
We have released a number of fixes and adjusted our download cluster to compensate for the slow servers. The error rates have gone back to normal levels, but some customers still might be experiencing slowness during download.
Posted 22 days ago. Sep 23, 2019 - 15:05 UTC
Update
We are adding capacity to our download cluster to relieve the load and unblock downloads. It might be possible that your download will be interrupted - in that case please try to resume it or start it again.
Posted 22 days ago. Sep 23, 2019 - 13:18 UTC
Identified
We have identified an issue impacting multiple downloaders in EU experiencing very slow download speeds. Working on fixing the issue.
Posted 22 days ago. Sep 23, 2019 - 11:18 UTC
This incident affected: Downloads.