Service Degradation in US due to Infrastructure provider operational issue

Incident Report for WeTransfer

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 22:13 UTC

Monitoring

Performances are still degraded in US due to some issues of our Infrastructure provider
Posted Oct 20, 2025 - 15:01 UTC
This incident affected: WeTransfer (Website, Downloads, Uploads).