Unexpected issues
Incident Report for WeTransfer
Resolved
We have rolled out a fix and all issues with our platform should be resolved by now. We'll continue to monitor the service for the time being, but all parts of it are operational again.
Posted 2 months ago. May 08, 2018 - 14:19 UTC
Identified
We're currently experiencing some issues with our platform. The website is unstable at best and might be unreachable for some of our users. We've identified the issue, and are working on a fix.
Posted 2 months ago. May 08, 2018 - 13:36 UTC