Delay in processing transfers
Incident Report for WeTransfer
Resolved
Delays have been resolved, the service is once again operating normally, this incident has been resolved. Thank you for your patience, we appreciate it hugely.
Posted May 28, 2020 - 19:55 UTC
Update
Our fix is operating as expected, and we are working through the backlog of transfers and processing them. This means that transfer uploads are processing more quickly than previously, however we are still seeing delays in uploading transfers and receiving confirmation emails when sending an email transfer.
Posted May 28, 2020 - 19:31 UTC
Monitoring
We have found the issue, and have put a fix in place. Due to the backlog of transfers to process we are seeing issues uploading, as well sending emails. As this backlog is worked through we expect that transfers will process increasingly quickly.
Posted May 28, 2020 - 18:30 UTC
This incident affected: WeTransfer (Uploads, Email).