Email delivery issues
Incident Report for WeTransfer
Resolved
While there may still be some lingering issues with the delivery of our emails due to factors outside of our control we see a return to normal for the majority of our users. We have closed this incident.
Posted Dec 16, 2020 - 07:34 UTC
Investigating
We're currently facing some issues with email delivery due to web-wide services being disrupted. While we investigate this issue further, your emails (delivery confirmations, download confirmations, verification codes, etc) might not reach their intended destination. Our suggestion, for the time being, is to create a link transfer or try a different email address.
Posted Dec 15, 2020 - 23:13 UTC
This incident affected: WeTransfer (Email).