Transfers not showing in Transfers overview side-pane
Incident Report for WeTransfer
Resolved
We have rolled out a fix and any transfers that you have sent or received, should now appear in the transfer overview side-pane as per usual.

Apologies for the inconvenience this might have caused. Happy transferring!
Posted Jul 25, 2024 - 09:49 UTC
Update
We're still working on a fix to ensure transfers are showing in the transfers overview side-pane.

Your transfers are safe with us and accessible through transfer links as per usual.
Posted Jul 25, 2024 - 09:19 UTC
Identified
We have identified an issue that prevents recent transfers from showing in a user's Transfers overview side-pane once successfully uploaded.

Your files are safe with us and our teams are currently working to remediate this. We will update you in the next 2 hours, or at the next status update (whichever comes first).
Posted Jul 25, 2024 - 07:44 UTC
This incident affected: WeTransfer (Website, Uploads).