EU downloads for boards and transfers delayed
Incident Report for WeTransfer
Resolved
The incident has been resolved - our EU download cluster is healthy again. We will keep monitoring.
Posted 29 days ago. Sep 16, 2019 - 20:27 UTC
Monitoring
We have found the likely cause of the issue, deployed additional download capacity in the EU region and are monitoring. Customers should no longer experience rejected download requests.
Posted 29 days ago. Sep 16, 2019 - 15:36 UTC
Update
While our engineers continue to monitor this issue we are pleased to provide an update. The problem was identified, a fix has been released and downloads on our EU servers have improved.
Posted 29 days ago. Sep 16, 2019 - 15:10 UTC
Investigating
Our engineers are currently investigating a delay in and/or failed downloads on our EU servers. Users downloading transfers and boards on our Collect app from our EU infrastructure might be experiencing refused downloads or slow download speeds.
Posted 29 days ago. Sep 16, 2019 - 11:59 UTC
This incident affected: Downloads.