Downloads are failing in the EU region

Incident Report for WeTransfer

Resolved

This incident has been resolved.
Posted Mar 30, 2023 - 10:38 UTC

Monitoring

A fix has been implemented and we are monitoring the results. We will update on this ASAP.
Posted Mar 30, 2023 - 10:31 UTC

Investigating

We are currently investigating an incident related to downloads failing in EU regions. This may also affect downloads via portals and reviews as well as transfers.
Posted Mar 30, 2023 - 10:09 UTC
This incident affected: WeTransfer (Downloads, Portals).