Latest Android app (v2.7.4) crashing on upload attempt
Incident Report for WeTransfer
Resolved
A new version of the WeTransfer app (v2.7.5) has been released in the Google Play Store that fixes this issue. Once you open the app, you will be prompted to update the app to the latest version.

Thank you for your patience and we apologise for any inconvenience this might have caused.
Posted May 30, 2024 - 17:19 UTC
Identified
We have observed the latest update of the WeTransfer Android app (v2.7.4) crashing when a user attempts an upload. As a workaround, please go to wetransfer.com for any uploads you need to perform. Make sure to login first so that any transfers/uploads are associated with your account.

Users on an older version of our Android app (2.7.3 and earlier) are not affected by this. We will notify you here again when a new/updated version is released on the Google Play Store.
Posted May 30, 2024 - 13:46 UTC
This incident affected: WeTransfer (Transfer Mobile).