Wetransfer.com is currently experiencing failures on downloads, uploads and other services
Incident Report for WeTransfer
Resolved
This incident has been resolved and our services are fully operational
Posted Sep 23, 2022 - 16:31 UTC
Monitoring
We have rolled out a fix and are currently monitoring, we are seeing improvements on our metrics
Posted Sep 23, 2022 - 15:24 UTC
Update
We are in the process of rolling out a change which may improve our error rate. This might still be affecting uploads, downloads, emails and possibly other parts of our service.
Posted Sep 23, 2022 - 14:15 UTC
Identified
We have identified the issue and are working on a solution
Posted Sep 23, 2022 - 13:15 UTC
Update
We are continuing to investigate this issue.
Posted Sep 23, 2022 - 09:57 UTC
Investigating
We are currently investigating the issue
Posted Sep 23, 2022 - 09:56 UTC
This incident affected: WeTransfer (Website, Pro, Downloads, Uploads, Email, Premium, Portals, Transfer Mobile).