Reduced download capacity and failing downloads in EU
Incident Report for WeTransfer
Resolved
With extra capacity and throttles in place downloads should now function normally.
Posted Nov 12, 2019 - 16:18 UTC
Monitoring
We have launched extra servers and taken steps to throttle transfers which were consuming too much load, the transfers in EU should now be downloading normally.
Posted Nov 12, 2019 - 16:08 UTC
Investigating
We have identified multiple users getting refused downloads in EU or having downloads running slow. At the moment we are adding extra download capacity.
Posted Nov 12, 2019 - 15:06 UTC
This incident affected: WeTransfer (Downloads).