EU Downloads not functioning
Incident Report for WeTransfer
Resolved
We identified the issue and have deployed a fix. We'll be monitoring the situation closely, but for now everything is working as it should again.
Posted 6 months ago. Feb 16, 2019 - 13:45 UTC
Update
We are continuing to investigate this issue.
Posted 6 months ago. Feb 16, 2019 - 12:42 UTC
Investigating
We're investigating an issue with our EU download servers. In the meanwhile, you might experience some disruptions in trying to use the service. We'll update the status page as we know more.
Posted 6 months ago. Feb 16, 2019 - 12:36 UTC
This incident affected: Downloads.