Short URLs not working
Incident Report for WeTransfer
Resolved
The incident has been fully resolved. This means that all short URLs - including those generated during the incident - are working again. Should any issues persist, clearing your cache should fix this.
Posted Feb 21, 2020 - 16:02 UTC
Identified
It came to our attention that our Short URLs are currently not functioning. That means that any URL with the prefix 'we.tl/...' won't redirect you to the proper page. You can still share the full URL with your recipients. Your transfers aren't affected. We're working on implementing a fix as soon as possible.
Posted Feb 21, 2020 - 12:31 UTC
This incident affected: WeTransfer (Downloads, Uploads, Email).