WeTransfer.com Outage
Incident Report for WeTransfer
Resolved
This incident has been resolved.
Posted Nov 05, 2020 - 11:12 UTC
Monitoring
Our systems are operational again, we're monitoring the situation.
Posted Nov 05, 2020 - 10:41 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 05, 2020 - 10:31 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 05, 2020 - 10:29 UTC
Identified
The issue behind outage of wetransfer.com has been identified and our teams are working on repairing the situation.
Posted Nov 05, 2020 - 10:29 UTC
This incident affected: WeTransfer (Website, Downloads, Uploads).