Users are unable to download new Paper Store Journals
Incident Report for WeTransfer
Resolved
We have mitigated the issue and new Paper Store journal downloads are available again!
Posted Aug 21, 2024 - 16:41 UTC
Identified
We have identified an issue affecting new Paper Store journal downloads, which could cause the Paper app to crash. Our team are currently working on a fix. We apologise for the inconvenience.
Posted Aug 21, 2024 - 15:02 UTC
This incident affected: Paper (Journal Store).