Downloads in EU
Incident Report for WeTransfer
Resolved
This incident has been resolved.
Posted Mar 23, 2020 - 15:36 UTC
Monitoring
Things are looking better, we're continuing to monitor.
Posted Mar 23, 2020 - 14:57 UTC
Identified
The issue has been identified and a fix rolled out. Users in Europe should start seeing their downloads succeed again.
Posted Mar 23, 2020 - 14:47 UTC
Investigating
We are currently investigating failing downloads for users in Europe.
Posted Mar 23, 2020 - 14:00 UTC
This incident affected: WeTransfer (Downloads).