Failed downloads for some of our users
Incident Report for WeTransfer
Resolved
This incident has been resolved.
Posted Jul 12, 2024 - 09:20 UTC
Monitoring
Our fix has been implemented and we are monitoring our results. We expect downloads to no longer fail. Will verify everything is resolved within the next 15 minutes.
Posted Jul 12, 2024 - 09:13 UTC
Identified
The underlying issue has been identified and we are working on a fix.
Posted Jul 12, 2024 - 09:09 UTC
Investigating
We are currently investigating an issue with our download servers resulting in failed downloads for some of our users. This downtime is currently affecting our web transfer services, WeTransfer mobile apps, portals and reviews, and Collect.
Posted Jul 12, 2024 - 08:35 UTC
This incident affected: WeTransfer (Website, Downloads, Uploads, Email, Portals, Transfer Mobile) and Collect.