The links from our emails are not currently working.
Incident Report for WeTransfer
Resolved
The links from our emails are operational again. If you still experience any issues with past links, please manually copy and paste the text URL into your browser or contact support.
Posted Mar 22, 2023 - 19:00 UTC
Investigating
We are currently investigating this issue.
Posted Mar 22, 2023 - 18:36 UTC
This incident affected: WeTransfer (Email).