We are observing significant improvements to this issue over time, though a small number of users may still have trouble accessing their links. If you are still having trouble, please refer to the previously suggested workaround. We will update again on the status of this outage as it develops.
Posted Nov 03, 2023 - 13:02 UTC
Monitoring
A fix has been implemented, and users can expect to see link access restored gradually. We will continue to monitor the situation.
If you are still unable to access your WeTransfer links, any broken links can still be accessed by replacing the we.tl section of the URL with go.wetransfer.com
For example: we.tl/abc123 can be changed to go.wetransfer.com/abc123 to be accessed again.
Posted Nov 02, 2023 - 16:45 UTC
Identified
We have identified the cause of this issue and are currently looking into a definitive solution. This issue affects WeTransfer links using the we.tl URL. In the meantime as a workaround, any broken links can be accessed by replacing the we.tl section of the URL with go.wetransfer.com
For example: we.tl/abc123 can be changed to go.wetransfer.com/abc123 to be accessed again.
Posted Nov 02, 2023 - 14:27 UTC
Update
We're currently facing an issue where certain WeTransfer links are not linking to the correct page. We are busy investigating this, together with our relevant partners, and hope to have this resolved soon. Thank you for your patience while we further investigate this issue and work on a resolution.