March 19th incident
Incident Report for WeTransfer
Resolved
We quickly identified the issue and fixed it - resulting in a fully functional service again. All parts of our product are up and running, and we'll continue to monitor the health of our service for the time being.
Posted 7 months ago. Mar 19, 2019 - 13:22 UTC
Investigating
Our transfer service is currently not reachable. We're investigating the issue and we'll update this page as soon as we have done so.
Posted 7 months ago. Mar 19, 2019 - 13:12 UTC
This incident affected: Website, Uploads, Downloads, and Support.