Failure to process uploads and transfer delivery on WeTransfer.com
Incident Report for WeTransfer
Resolved
This incident has been resolved and uploads have resumed to full functionality.
Posted May 31, 2021 - 13:20 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 31, 2021 - 11:42 UTC
Update
We are continuing to investigate this issue.
Posted May 31, 2021 - 11:30 UTC
Investigating
We have identified an issue with uploads on our platform. At the moment uploads are not successfully processing and will not be delivered, this also affects email confirmation delivery. We are currently investigating this issue.
Posted May 31, 2021 - 11:25 UTC
This incident affected: WeTransfer (Website, Pro, Uploads, Email).