Degraded performance on wetransfer.com
Incident Report for WeTransfer
Resolved
This incident has been resolved.
Posted May 13, 2021 - 07:12 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 12, 2021 - 22:53 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 12, 2021 - 21:50 UTC
Update
We are continuing to investigate this issue.
Posted May 12, 2021 - 21:33 UTC
Update
We are continuing to investigate this issue.
Posted May 12, 2021 - 21:00 UTC
Update
We are continuing to investigate this issue.
Posted May 12, 2021 - 20:37 UTC
Investigating
After today's earlier incident, we're seeing that some users are experiencing errors or degraded performance again. This may affect transfer uploads and downloads, and cause delays in our email delivery. We are currently investigating this issue.
Posted May 12, 2021 - 20:35 UTC
This incident affected: WeTransfer (Website, Downloads, Uploads, Email).