Downloads to EU servers and file previews unavailable
Incident Report for WeTransfer
Resolved
This incident has now been resolved. The service is restored to functionality.
Posted Sep 20, 2021 - 15:15 UTC
Monitoring
A fix has been implemented and downloads are fully resumable with previews functional as well. This incident is now being monitored.
Posted Sep 20, 2021 - 15:07 UTC
Identified
We have identified the root cause of the issue and are working on establishing a fix. Downloads are currently intermittent and may resume with some delay.
Posted Sep 20, 2021 - 14:33 UTC
Investigating
We are currently investigating an incident on our servers within the EU. This means that many of our EU based users will not be able to download their files or preview them and will see an error window instead. Please bear with us while we work hard to fix this as quickly as possible.
Posted Sep 20, 2021 - 13:38 UTC
This incident affected: WeTransfer (Website, Pro, Downloads).