Incident on downloads
Incident Report for WeTransfer
Resolved
This incident has been resolved.
Posted Feb 26, 2020 - 13:46 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 26, 2020 - 13:25 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 26, 2020 - 13:22 UTC
Investigating
We have identified an issue with our download servers and are releasing a fix as soon as possible. This currently affects downloads for all transfers.
Posted Feb 26, 2020 - 13:08 UTC
This incident affected: Downloads.