Incident 14th of December 2018
Incident Report for WeTransfer
Resolved
This incident has been resolved.
Posted 3 months ago. Dec 14, 2018 - 18:10 UTC
Investigating
We are currently experiencing some issues with the platform, resulting in an unreachable service for some of our users and slow performance for others. We're investigating the issue and will roll out a fix as soon as possible.
Posted 3 months ago. Dec 14, 2018 - 16:36 UTC
This incident affected: Website, Uploads, Downloads, Email, and Support.