Unable to access WeTransfer.com

Incident Report for WeTransfer

Resolved

The incident has been resolved.
Posted Oct 30, 2023 - 21:26 UTC

Investigating

Our engineers are continuing to work hard to investigate the issue.
Posted Oct 30, 2023 - 20:38 UTC
This incident affected: WeTransfer (Website, Downloads, Uploads, Email, Portals).