Retry payment flow is broken
Incident Report for WeTransfer
Resolved
This incident has been resolved. Thank you for your patience!
Posted Oct 13, 2023 - 19:12 UTC
Update
We are continuing to work on a fix for this issue. We hope to have an update as soon as possible.
Posted Oct 13, 2023 - 17:59 UTC
Identified
We have identified the issue and a fix is in review. We are hoping to implement the fix as soon as possible.
Posted Oct 13, 2023 - 16:09 UTC
Investigating
We have received reports from users that they are unable to complete their payment after exiting our payment flow and revisiting. We are currently investigating this issue and working hard to implement a fix.

If you are experiencing this issue, please reach out to our Support team via: http://we.tl/support
Posted Oct 13, 2023 - 15:52 UTC
This incident affected: WeTransfer (Website, Portals, Transfer Mobile).