Possible delayed email deliveries
Incident Report for WeTransfer
Resolved
We have not noticed any customer impact regarding email delays and are closing active investigation. We’ll continue mitigating with our email provider and will update here if needed.
Posted Jul 28, 2020 - 15:36 UTC
Update
We are continuing to investigate this issue.
Posted Jul 28, 2020 - 13:41 UTC
Investigating
We've identified an issue with our email provider which may cause our email deliveries to be delayed. In the meantime, you can send link transfers. We'll update here when the situation changes.
Posted Jul 28, 2020 - 13:16 UTC
This incident affected: Email.