Uploads across products may be slow

Incident Report for WeTransfer

Resolved

Thanks for your patience, we have resolved the issue and services are back to normal.
Posted Jun 14, 2023 - 21:44 UTC

Monitoring

We implemented a fix and we're monitoring to ensure no further issues with file uploads
Posted Jun 14, 2023 - 21:38 UTC

Update

We're still troubleshooting solutions to resolve the issue with our upload service
Posted Jun 14, 2023 - 21:19 UTC

Investigating

We are investigating an issue with our upload service which is causing slowness to users
Posted Jun 14, 2023 - 20:51 UTC
This incident affected: WeTransfer (Website, Downloads, Uploads, Email, Portals, Transfer Mobile) and WeTransfer, Support.