Downtime on WeTransfer downloads
Incident Report for WeTransfer
Resolved
This incident has been resolved and all download URLs are back in working order. Please refresh your page and try your download link again in your browser.
Posted Jun 17, 2021 - 14:11 UTC
Investigating
We are currently investigating an issue with download URLs not working. We have identified that transfers to download are not loading correctly and/or are being redirected to wetransfer.net.
Posted Jun 17, 2021 - 12:25 UTC
This incident affected: WeTransfer (Website, Downloads).