Intermittent download failures
Incident Report for WeTransfer
Resolved
System status has returned to normal. Apologies for the disruption.
Posted 5 months ago. May 08, 2019 - 09:47 UTC
Monitoring
We believe our download systems have returned to normal. We will continue monitoring.
Posted 5 months ago. May 08, 2019 - 09:05 UTC
Investigating
We have reports of intermittently failing or delayed downloads. We are investigating and will update this page when we know more.
Posted 5 months ago. May 08, 2019 - 07:57 UTC
This incident affected: Downloads.