Delay in email notifications and transfer information in account.
Incident Report for WeTransfer
Resolved
We're happy to inform we are up and running again.

All notifications are working correctly and there is no delay in our email delivery.

If you are still missing any emails, don't forget to check your spam/junk folder and make sure to add noreply@wetransfer.com to your trusted contacts.

Thank you for all your patience while we resolved this issue.
Posted Mar 11, 2024 - 22:12 UTC
Monitoring
We've identified the problem with the recovery and a fix has been applied. We are seeing improvements, but there are still delays with getting our email notifications. We are getting trough the backlog of emails and monitoring further.
Posted Mar 11, 2024 - 20:11 UTC
Investigating
We are currently investigating this issue and looking into it with our service providers.
Posted Mar 11, 2024 - 18:47 UTC
This incident affected: WeTransfer (Website, Downloads, Uploads, Email).