Plus log-in broken
Incident Report for WeTransfer
Resolved
We've rolled back recent changes to the platform, which fixes the log-in problem. If you continue to have trouble logging in, please try to reset your password again to access your Plus account.
Posted 9 months ago. Feb 24, 2017 - 14:12 UTC
Identified
We've identified an issue for Plus users, where users are having trouble logging into their account. We're working on a fix as we speak, and will update you when we have it in place.
Posted 9 months ago. Feb 24, 2017 - 13:52 UTC