Outage
Incident Report for WeTransfer
Resolved
This incident has been resolved.
Posted 11 months ago. Dec 15, 2016 - 15:25 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 11 months ago. Dec 15, 2016 - 14:30 UTC
Investigating
We are experiencing a severe drop in performance on the main website, which we are currently investigating. Update will follow when we know more.
Posted 11 months ago. Dec 15, 2016 - 14:13 UTC