Downtime
Incident Report for WeTransfer
Resolved
We can confirm that the issues from earlier have been resolved by carefully rolling back some earlier releases. Trust that we will keep monitoring the situation closely during the remainder of the day.
Posted 8 months ago. Apr 04, 2017 - 13:19 UTC
Investigating
It seems our servers are currently having a hard time keeping up with demand after changing our email templates earlier today. As a result - our homepage and other services seem to be unavailable at the moment. Please bear with us while we investigate the issue.
Posted 8 months ago. Apr 04, 2017 - 12:50 UTC