Failing uploads and downloads US
Incident Report for WeTransfer
Resolved
New uploads for the Americas are being directed to the US storage, which is our normal configuration.
Posted 5 months ago. Mar 02, 2017 - 13:44 UTC
Update
Following the stabilisation of AWS S3 us-east-1 we have reenabled downloads for transfers in the US. We are going to be monitoring the S3 service before we default the US uploads back to the US-based endpoints.
Posted 5 months ago. Feb 28, 2017 - 23:09 UTC
Monitoring
We are waiting on AWS to stabilise S3 in the US to reenable downloads of the transfers located in the US. Uploads are being directed to our EU storage.
Posted 5 months ago. Feb 28, 2017 - 21:11 UTC
Update
We have redirected all of our Americas customers to our servers in Europe for the new transfers. The transfers currently in transit to the US region will likely fail, but should succeed upon restart.

Downloading the transfers stored in the US region is still not possible at the moment.
Posted 5 months ago. Feb 28, 2017 - 18:38 UTC
Identified
We are currently having difficulties processing uploads and downloads that originate from our customers in the Americas. This is likely related to the AWS S3 problems others are observing. Since this is causing timeouts on other services, more of our systems are affected.
Posted 5 months ago. Feb 28, 2017 - 18:27 UTC