Unable to complete payments via www.wetransfer.com
Incident Report for WeTransfer
Resolved
Thank you for your patience. This incident has been resolved. It is now possible to sign up and pay for subscriptions with all payment methods on our website again. If you were trying to sign up while this incident was ongoing, we expect your payment to be processed by now. However, it could be the case that you will not be able to use your new subscription straight away. We suggest doing a password reset on your account (through "Forgot password?") or reaching out to our customer support team if you cannot use your new subscription. We are sorry for any inconvenience caused.
Posted Apr 12, 2024 - 18:58 UTC
Monitoring
A fix has been implemented and we are monitoring if it has been successful. We expect payment processing to be slow until we mark this incident as resolved. Will update once everything is back to normal.
Posted Apr 12, 2024 - 18:29 UTC
Identified
We have identified and a fix and are working on release.
Posted Apr 12, 2024 - 18:20 UTC
Investigating
We are currently investigating this issue and are working on identifying a fix. At the moment, you will be unable to complete payments via www.wetransfer.com. As a workaround, you can sign up for a new subscription through one of our mobile apps using Play or App Store.
Posted Apr 12, 2024 - 17:52 UTC
This incident affected: WeTransfer (Website).